On Wed, Nov 10, 2021 at 09:04:34PM +0100, Ansuel Smith wrote: > On Tue, Nov 09, 2021 at 10:09:40PM +0100, Andrew Lunn wrote: > > > > +/* Expose sysfs for every blink to be configurable from userspace */ > > > > +DEFINE_OFFLOAD_TRIGGER(blink_tx, BLINK_TX); > > > > +DEFINE_OFFLOAD_TRIGGER(blink_rx, BLINK_RX); > > > > +DEFINE_OFFLOAD_TRIGGER(keep_link_10m, KEEP_LINK_10M); > > > > +DEFINE_OFFLOAD_TRIGGER(keep_link_100m, KEEP_LINK_100M); > > > > +DEFINE_OFFLOAD_TRIGGER(keep_link_1000m, KEEP_LINK_1000M); > > > > You might get warnings about CamelCase, but i suggest keep_link_10M, > > keep_link_100M and keep_link_1000M. These are megabits, not millibits. > > > > > > +DEFINE_OFFLOAD_TRIGGER(keep_half_duplex, KEEP_HALF_DUPLEX); > > > > +DEFINE_OFFLOAD_TRIGGER(keep_full_duplex, KEEP_FULL_DUPLEX); > > > > What does keep mean in this context? > > > > LED is turned on but doesn't blink. Hint for a better name? I would just drop the keep. You have blink_ as a prefix for those modes that blink. Andrew