On Mon, 2021-09-27 at 11:43 -0600, Jonathan Corbet wrote: > Utkarsh Verma <utkarshverma294@xxxxxxxxx> writes: > > > Added and documented 3 new message types: > > - UNNECESSARY_INT > > - UNSPECIFIED_INT > > - UNNECESSARY_ELSE > > > > Signed-off-by: Utkarsh Verma <utkarshverma294@xxxxxxxxx> > > --- > > Documentation/dev-tools/checkpatch.rst | 47 ++++++++++++++++++++++++++ > > 1 file changed, 47 insertions(+) > > So...when you send multiple patches with the same subject line that's > always a bad sign. We really want a "git --oneline" listing to give a > good idea of what the patch does, and that depends on more descriptive > subject lines. > > In this case, something like: > > docs: checkpatch: add UNNECESSARY/UNSPECIFIED_INT and UNNECESSARY_ELSE > > I can fix up these two patches, but please try to keep this in mind for > future work. > > (applying the patches now). The unnecessary_else description isn't particularly good as the checkpatch output doesn't describe multiple if/else if/else if type returns where the message should not apply. For this type of use, the checkpatch message is not necessarily correct and because it could be a patch context, there's no way for checkpatch to know if it's correct or not. if (foo) { ... } else if (bar) { ... return [val]; } else { ... }