On Mon, Feb 19, 2024 at 11:40 PM Anna-Maria Behnsen <anna-maria@xxxxxxxxxxxxx> wrote: > > There is already a generic union definition for vdso_data_store in vdso > datapage header. > > Use this definition to prevent code duplication. > > Signed-off-by: Anna-Maria Behnsen <anna-maria@xxxxxxxxxxxxx> > Cc: Guo Ren <guoren@xxxxxxxxxx> > Cc: linux-csky@xxxxxxxxxxxxxxx > --- > arch/csky/kernel/vdso.c | 10 ++-------- > 1 file changed, 2 insertions(+), 8 deletions(-) > > diff --git a/arch/csky/kernel/vdso.c b/arch/csky/kernel/vdso.c > index e74a2504d331..2ca886e4a458 100644 > --- a/arch/csky/kernel/vdso.c > +++ b/arch/csky/kernel/vdso.c > @@ -15,14 +15,8 @@ extern char vdso_start[], vdso_end[]; > static unsigned int vdso_pages; > static struct page **vdso_pagelist; > > -/* > - * The vDSO data page. > - */ > -static union { > - struct vdso_data data; > - u8 page[PAGE_SIZE]; > -} vdso_data_store __page_aligned_data; > -struct vdso_data *vdso_data = &vdso_data_store.data; > +static union vdso_data_store vdso_data_store __page_aligned_data; > +struct vdso_data *vdso_data = vdso_data_store.data; > > static int __init vdso_init(void) > { > -- > 2.39.2 > Acked-by: Guo Ren <guoren@xxxxxxxxxx> -- Best Regards Guo Ren