On Fri Mar 1, 2024 at 10:47 PM EET, Stefan Berger wrote: > > > On 3/1/24 15:41, Jarkko Sakkinen wrote: > > On Fri Mar 1, 2024 at 4:20 AM EET, Stefan Berger wrote: > >> In some cases the name keylen does not reflect the purpose of the variable > >> anymore once NIST P521 is used but it is the size of the buffer. There- > >> for, rename keylen to bufsize where appropriate. > >> > >> Signed-off-by: Stefan Berger <stefanb@xxxxxxxxxxxxx> > >> --- > >> crypto/ecdsa.c | 12 ++++++------ > >> 1 file changed, 6 insertions(+), 6 deletions(-) > >> > >> diff --git a/crypto/ecdsa.c b/crypto/ecdsa.c > >> index 4daefb40c37a..4e847b59622a 100644 > >> --- a/crypto/ecdsa.c > >> +++ b/crypto/ecdsa.c > >> @@ -35,8 +35,8 @@ struct ecdsa_signature_ctx { > >> static int ecdsa_get_signature_rs(u64 *dest, size_t hdrlen, unsigned char tag, > >> const void *value, size_t vlen, unsigned int ndigits) > >> { > >> - size_t keylen = ndigits * sizeof(u64); > >> - ssize_t diff = vlen - keylen; > >> + size_t bufsize = ndigits * sizeof(u64); > > > > why not just "* 8"? using sizeof here makes this function only unreadable. > > 'unreadable' is a 'strong' word ... so what is the gain when writing sizeof(u64)? BR, Jarkko