On Fri, Mar 10, 2023 at 11:30:27PM +0100, Krzysztof Kozlowski wrote: > > diff --git a/drivers/crypto/img-hash.c b/drivers/crypto/img-hash.c > index fe93d19e3044..4e9a6660d791 100644 > --- a/drivers/crypto/img-hash.c > +++ b/drivers/crypto/img-hash.c > @@ -1106,7 +1106,7 @@ static struct platform_driver img_hash_driver = { > .driver = { > .name = "img-hash-accelerator", > .pm = &img_hash_pm_ops, > - .of_match_table = of_match_ptr(img_hash_match), > + .of_match_table = img_hash_match, I think we should keep this because this driver doesn't explicitly depend on OF. Sure of_match_table is unconditionally defined but I'd call that a bug instead of a feature :) However, I would take this if you resend it with a Kconfig update to add an explicit dependency on OF. Thanks, -- Email: Herbert Xu <herbert@xxxxxxxxxxxxxxxxxxx> Home Page: http://gondor.apana.org.au/~herbert/ PGP Key: http://gondor.apana.org.au/~herbert/pubkey.txt