Hi Elliott,
Thank you so much for the review!
On 12/10/22 04:16, Elliott, Robert (Servers) wrote:
>
>
>> -----Original Message-----
>> From: Taehee Yoo <ap420073@xxxxxxxxx>
>> Sent: Wednesday, December 7, 2022 7:59 AM
>> Subject: [PATCH v7 3/4] crypto: aria: implement aria-avx2
>>
> ...
>> diff --git a/arch/x86/crypto/aria-avx.h b/arch/x86/crypto/aria-avx.h
>> index 01e9a01dc157..b997c4888fb7 100644
>> --- a/arch/x86/crypto/aria-avx.h
>> +++ b/arch/x86/crypto/aria-avx.h
>> @@ -7,10 +7,48 @@
>> #define ARIA_AESNI_PARALLEL_BLOCKS 16
>> #define ARIA_AESNI_PARALLEL_BLOCK_SIZE (ARIA_BLOCK_SIZE * 16)
>>
>> +#define ARIA_AESNI_AVX2_PARALLEL_BLOCKS 32
>> +#define ARIA_AESNI_AVX2_PARALLEL_BLOCK_SIZE (ARIA_BLOCK_SIZE * 32)
>
> I think those _SIZE macros should use the _BLOCKS macros rather
> than hardcode those numbers:
>
> #define ARIA_AESNI_PARALLEL_BLOCK_SIZE (ARIA_BLOCK_SIZE *
ARIA_AESNI_PARALLEL_BLOCKS)
> #define ARIA_AESNI_AVX2_PARALLEL_BLOCK_SIZE (ARIA_BLOCK_SIZE *
ARIA_AESNI_AVX2_PARALLEL_BLOCKS)
>
I agree with it.
I will replace the magic numbers with the _BLOCK macros in the v8 patch.
Thanks a lot!
Taehee Yoo