On Fri, Nov 18, 2022 at 3:16 PM Petr Mladek <pmladek@xxxxxxxx> wrote: > > + return 0; > > I believe that we should rather return NOTIFY_DONE here. > It is rather a formal change. The value is 0 as well. > > That said, I have never really understood the difference between > NOTIFY_OK and NOTIFY_DONE. Ah yes, the varying degrees of apathy: #define NOTIFY_DONE 0x0000 /* Don't care */ #define NOTIFY_OK 0x0001 /* Suits me */ In a sense, the fact that there's this return value at all indicates a notifier block isn't *quite* the API we want, since this happens only once and it really should never stop. But it's so convenient and small to use that I think it's fine. Anyway, I'll use the right constant here as you suggested. Jason