On 2021/11/4 14:19, davidcomponentone@xxxxxxxxx wrote: > From: Yang Guang <yang.guang5@xxxxxxxxxx> > > Use the macro 'swap()' defined in 'include/linux/minmax.h' to avoid > opencoding it. > > Reported-by: Zeal Robot <zealci@xxxxxxxxxx> > Signed-off-by: Yang Guang <yang.guang5@xxxxxxxxxx> > --- > drivers/crypto/hisilicon/hpre/hpre_crypto.c | 5 +---- > 1 file changed, 1 insertion(+), 4 deletions(-) > > diff --git a/drivers/crypto/hisilicon/hpre/hpre_crypto.c b/drivers/crypto/hisilicon/hpre/hpre_crypto.c > index a032c192ef1d..0f1724d355b8 100644 > --- a/drivers/crypto/hisilicon/hpre/hpre_crypto.c > +++ b/drivers/crypto/hisilicon/hpre/hpre_crypto.c > @@ -1177,13 +1177,10 @@ static void hpre_rsa_exit_tfm(struct crypto_akcipher *tfm) > static void hpre_key_to_big_end(u8 *data, int len) > { > int i, j; > - u8 tmp; > > for (i = 0; i < len / 2; i++) { > j = len - i - 1; > - tmp = data[j]; > - data[j] = data[i]; > - data[i] = tmp; > + swap(data[j], data[i]); > } > } > > OK! Thanks. Longfang.