On Tue, 15 Sep 2020 at 13:02, Horia Geantă <horia.geanta@xxxxxxx> wrote: > > On 9/14/2020 9:20 PM, Ard Biesheuvel wrote: > > On Mon, 14 Sep 2020 at 20:12, Horia Geantă <horia.geanta@xxxxxxx> wrote: > >> > >> On 9/14/2020 7:28 PM, Ard Biesheuvel wrote: > >>> On Mon, 14 Sep 2020 at 19:24, Horia Geantă <horia.geanta@xxxxxxx> wrote: > >>>> > >>>> On 9/9/2020 1:10 AM, Herbert Xu wrote: > >>>>> On Tue, Sep 08, 2020 at 01:35:04PM +0300, Horia Geantă wrote: > >>>>>> > >>>>>>> Just go with the get_unaligned unconditionally. > >>>>>> > >>>>>> Won't this lead to sub-optimal code for ARMv7 > >>>>>> in case the IV is aligned? > >>>>> > >>>>> If this should be optimised in ARMv7 then that should be done > >>>>> in get_unaligned itself and not open-coded. > >>>>> > >>>> I am not sure what's wrong with avoiding using the unaligned accessors > >>>> in case data is aligned. > >>>> > >>>> Documentation/core-api/unaligned-memory-access.rst clearly states: > >>>> These macros work for memory accesses of any length (not just 32 bits as > >>>> in the examples above). Be aware that when compared to standard access of > >>>> aligned memory, using these macros to access unaligned memory can be costly in > >>>> terms of performance. > >>>> > >>>> So IMO it makes sense to use get_unaligned() only when needed. > >>>> There are several cases of users doing this, e.g. siphash. > >>>> > >>> > >>> For ARMv7 code, using the unaligned accessors unconditionally is fine, > >>> and it will not affect performance. > >>> > >>> In general, when CONFIG_HAVE_EFFICIENT_UNALIGNED_ACCESS is defined, > >>> you can use the unaligned accessors. If it is not, it helps to have > >>> different code paths. > >>> > >> arch/arm/include/asm/unaligned.h doesn't make use of > >> linux/unaligned/access_ok.h, even if CONFIG_HAVE_EFFICIENT_UNALIGNED_ACCESS > >> is set. > >> > >> I understand the comment in the file, however using get_unaligned() > >> unconditionally takes away the opportunity to generate optimized code > >> (using ldrd/ldm) when data is aligned. > >> > > > > But the minimal optimization that is possible here (one ldrd/ldm > > instruction vs two ldr instructions) is defeated by the fact that you > > are using a conditional branch to select between the two. And this is > > not even a hot path to begin with, > > > This is actually on the hot path (encrypt/decrypt callbacks), > but you're probably right that the conditional branching is going to offset > the optimized code. > This is called once per XTS request, right? And you are saying the extra cycle makes a difference? > To avoid branching, code could be rewritten as: > > #ifdef CONFIG_HAVE_EFFICIENT_UNALIGNED_ACCESS > size = *(u64 *)(req->iv + (ivsize / 2)); > #else > size = get_unaligned((u64 *)(req->iv + (ivsize / 2))); > #endif > > however in this case ARMv7 would suffer since > CONFIG_HAVE_EFFICIENT_UNALIGNED_ACCESS=y and > ldrd/ldm for accesses not word-aligned are inefficient - lead to traps. > CONFIG_HAVE_EFFICIENT_UNALIGNED_ACCESS means 'just use the unaligned accessors as they are basically free'. Casting a potentially misaligned u8* to a u64* is not permitted by the C standard. > Would it be ok to use: > #if defined(CONFIG_HAVE_EFFICIENT_UNALIGNED_ACCESS) && !defined(CONFIG_ARM) > to workaround the ARMv7 inconsistency? > No, please just use the get_unaligned() accessor.