On Wed, Jan 22, 2020 at 5:37 AM Horia Geanta <horia.geanta@xxxxxxx> wrote: > > On 1/21/2020 6:38 PM, Horia Geanta wrote: > > On 1/8/2020 5:42 PM, Andrey Smirnov wrote: > >> @@ -275,12 +276,25 @@ static int instantiate_rng(struct device *ctrldev, int state_handle_mask, > >> return -ENOMEM; > >> > >> for (sh_idx = 0; sh_idx < RNG4_MAX_HANDLES; sh_idx++) { > >> + const u32 rdsta_if = RDSTA_IF0 << sh_idx; > >> + const u32 rdsta_pr = RDSTA_PR0 << sh_idx; > >> + const u32 rdsta_mask = rdsta_if | rdsta_pr; > >> /* > >> * If the corresponding bit is set, this state handle > >> * was initialized by somebody else, so it's left alone. > >> */ > >> - if ((1 << sh_idx) & state_handle_mask) > >> - continue; > >> + if (rdsta_if & state_handle_mask) { > >> + if (rdsta_pr & state_handle_mask) > > instantiate_rng() is called with > > state_handle_mask = rd_reg32(&ctrl->r4tst[0].rdsta) & RDSTA_IFMASK; > > so if (rdsta_pr & state_handle_mask) will always be false, > > leading to unneeded state handle re-initialization. > > > Sorry, I missed this change: > -#define RDSTA_IFMASK (RDSTA_IF1 | RDSTA_IF0) > +#define RDSTA_IFMASK (RDSTA_PR1 | RDSTA_PR0 | RDSTA_IF1 | RDSTA_IF0) > > which means code is correct (though I must admit not so intuitive). Renamed this to RDSTA_MASK in v7, to, hopefully make things more clear. Thanks, Andrey Smirnov