Hi, the patchset implements cleanups suggested by Eric in https://lore.kernel.org/linux-crypto/20191025051550.GA103313@sol.localdomain/ The diff is almost the same, split into pieces with some additional comments where it would help understand the simplifications. This is based on v7 of the BLAKE2b patchset. The self-tests have been run for each patch on x86_64. V2: - rename digest_setkey to blake2b_setkey, this is in patch 7 that also does a rename, to avoid a too-trivial separate patch - minor withespace fix in patch 6 David Sterba (7): crypto: blake2b: merge _final implementation to callback crypto: blake2b: merge blake2 init to api callback crypto: blake2b: simplify key init crypto: blake2b: delete unused structs or members crypto: blake2b: open code set last block helper crypto: blake2b: merge _update to api callback crypto: blake2b: rename tfm context and _setkey callback crypto/blake2b_generic.c | 279 ++++++++++++--------------------------- 1 file changed, 82 insertions(+), 197 deletions(-) -- 2.23.0