On Thu, Jun 07, 2018 at 12:16:16PM -0700, Kees Cook wrote: > On Thu, Jun 7, 2018 at 12:12 PM, Eric Biggers <ebiggers3@xxxxxxxxx> wrote: > > From: Eric Biggers <ebiggers@xxxxxxxxxx> > > > > Commit 383203eff718 ("dh key: get rid of stack allocated array") changed > > kdf_ctr() to assume that the length of key material to derive is a > > multiple of the digest size. The length was supposed to be rounded up > > accordingly. However, the round_up() macro was used which only gives > > the correct result on power-of-2 arguments, whereas not all hash > > algorithms have power-of-2 digest sizes. In some cases this resulted in > > a write past the end of the 'outbuf' buffer. > > > > Fix it by switching to roundup(), which works for non-power-of-2 inputs. > > round_up() vs roundup(). Wow, that's not confusing. :( I wonder if we > should rename the former to roundup_pow2() or something? Yes, it's very confusing, and I wish the names were clearer, or that there was one macro that just did the right thing (but then the power-of-2 optimization could only be done for constants, where it might not be necessary anyway). roundup_pow2() would still be confused with roundup_pow_of_two(), unfortunately. Eric