On Mon, Sep 21, 2015 at 02:29:18PM +0900, Sergey Senozhatsky wrote: > On (09/18/15 14:19), Joonsoo Kim wrote: > > -/* Never return NULL, may sleep */ > > +/* May return NULL, may sleep */ > > struct zcomp_strm *zcomp_decompress_begin(struct zcomp *comp) > > { > > + if (comp->tfm_noctx) > > + return NULL; > > + > > return zcomp_strm_find(comp); > > } > > > > @@ -346,11 +349,18 @@ int zcomp_decompress(struct zcomp *comp, struct zcomp_strm *zstrm, > > { > > unsigned int size = PAGE_SIZE; > > > > + if (!zstrm) { > > + return crypto_comp_decompress_noctx(comp->tfm_noctx, > > + src, src_len, dst, &size); > > + } > > unneeded braces. It's more readable for me. But, if you don't like it, I will remove brace. Thanks. -- To unsubscribe from this list: send the line "unsubscribe linux-crypto" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html