On Wed, Mar 11, 2015 at 03:46:18PM -0700, Tadeusz Struk wrote: > AIO interface should prefer AIO operations over iter_op What the devil for? read_iter and write_iter *ARE* aio operations, as much as soon to be removed aio_read and aio_write. And yes, those are going to be removed very soon. Note that ->read_iter() and ->write_iter() are getting iocb pointer passed to them. It's just that socket instances are not passing it along to ->sendmsg/->recvmsg anymore. And why, in name of everything unholy, do your methods get redundant total_len argument? It's iov_iter_count(&msg->msg_iter) (and in iov_iter-net I have an inline helper doing that - enough places open-coding that thing). If nothing else, ->sendmsg() and ->recvmsg() would benefit from removing that argument as well. I have patches doing that, but iocb removal conflicts with them and they need to be rebased to current net/master... -- To unsubscribe from this list: send the line "unsubscribe linux-crypto" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html