> -----Original Message----- > From: Kim Phillips [mailto:kim.phillips@xxxxxxxxxxxxx] > Sent: Saturday, May 03, 2014 5:40 AM > To: Garg Vakul-B16394 > Cc: linux-crypto@xxxxxxxxxxxxxxx; herbert@xxxxxxxxxxxxxxxxxxx; Geanta > Neag Horia Ioan-B05471; Gupta Ruchika-R66431; Porosanu Alexandru-B06830 > Subject: Re: [PATCH] crypto: caam - Fix key inlining in AEAD shared > descriptors > > On Sun, 27 Apr 2014 11:26:14 -0400 > Vakul Garg <vakul@xxxxxxxxxxxxx> wrote: > > > The variable 'keys_fit_inline' is initialised correctly to avoid using > > its stale value while creating shared descriptor for decryption and > > given-iv-encryption. > > you mean givencrypt? That's "generate an IV and encrypt". I will modify it and submit next patch version. > > > @@ -220,6 +220,8 @@ static int aead_null_set_sh_desc(struct crypto_aead > *aead) > > if (DESC_AEAD_NULL_ENC_LEN + DESC_JOB_IO_LEN + > > ctx->split_key_pad_len <= CAAM_DESC_BYTES_MAX) > > keys_fit_inline = true; > > + else > > + keys_fit_inline = false; > > Can we do the easier to read: > > keys_fit_inline = false; > if (DESC_AEAD_NULL_ENC_LEN + DESC_JOB_IO_LEN + > ctx->split_key_pad_len <= CAAM_DESC_BYTES_MAX) > keys_fit_inline = true; > > ? Why pre-init a variable with default value when it could be overwritten? I think that the form I submitted is equally easy to read. > > Thanks. > > Kim -- To unsubscribe from this list: send the line "unsubscribe linux-crypto" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html