Patches 1-2 add new tests and test vectors for camellia. Patches 3-5 rename 'camellia' module to 'camellia_generic'. Patch 6 adds x86_64 implementation of camellia. Series depends on patch: http://marc.info/?l=linux-crypto-vger&m=133077599602729&w=2 --- Jussi Kivilinna (6): crypto: testmgr - add more camellia test vectors crypto: tcrypt - add more camellia tests crypto: camellia - rename camellia module to camellia_generic crypto: camellia - fix checkpatch warnings crypto: camellia - rename camellia.c to camellia_generic.c crypto: camellia - add assembler implementation for x86_64 arch/x86/crypto/Makefile | 2 arch/x86/crypto/camellia-x86_64-asm_64.S | 521 ++++++++ arch/x86/crypto/camellia_glue.c | 1953 ++++++++++++++++++++++++++++++ crypto/Kconfig | 18 crypto/Makefile | 2 crypto/camellia.c | 1098 ----------------- crypto/camellia_generic.c | 1102 +++++++++++++++++ crypto/tcrypt.c | 12 crypto/testmgr.c | 45 + crypto/testmgr.h | 1383 +++++++++++++++++++++ 10 files changed, 5033 insertions(+), 1103 deletions(-) create mode 100644 arch/x86/crypto/camellia-x86_64-asm_64.S create mode 100644 arch/x86/crypto/camellia_glue.c delete mode 100644 crypto/camellia.c create mode 100644 crypto/camellia_generic.c -- -- To unsubscribe from this list: send the line "unsubscribe linux-crypto" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html