On 12/11/10 20:11, David Howells wrote:
David Safford<safford@xxxxxxxxxxxxxx> wrote:
David, does this look ok to you? If so, I will do two patches, one to
fix the helper name throughout the existing tpm.c, and then a new
version of the tpm_send patch which uses the new name.
I prefer my suggestion: Wrapping the module_put() up so that you don't see it
directly. Then you don't need to alter tpm_chip_find_get(). I'll argue that
you don't need to know how tpm_chips are got/put, except in the code that
wraps it.
tpm_chip_find_get() not only gets the tpm_chip, but also searches for it
given an index in a tpm_chip_list.
tpm_chip_put() is then the name that fits the argument here, given it'll
only be a wrapper of the tpm_chip put
functionality, not the searching one I assume.
I'll ack any of the two approaches (tpm_chip_put or tpm_chip_find_get
renaming) in any case.
Rajiv
--
To unsubscribe from this list: send the line "unsubscribe linux-crypto" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html