Re: [RFC PATCH] [XFRM] xfrm_algo: correct usage of RIPEMD-160

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



* Adrian-Ken Rueegsegger | 2008-06-01 19:16:18 [+0200]:

>This patch fixes the usage of RIPEMD-160 in xfrm_algo which in turn
>allows hmac(rmd160) to be used as authentication mechanism in IPsec
>ESP and AH (see RFC 2857).
>
>Signed-off-by: Adrian-Ken Rueegsegger <rueegsegger@xxxxxxxxxxx>
>---
> net/xfrm/xfrm_algo.c |    4 ++--
> 1 files changed, 2 insertions(+), 2 deletions(-)
>
>diff --git a/net/xfrm/xfrm_algo.c b/net/xfrm/xfrm_algo.c
>index ac765dd..23a2cc0 100644
>--- a/net/xfrm/xfrm_algo.c
>+++ b/net/xfrm/xfrm_algo.c
>@@ -200,8 +200,8 @@ static struct xfrm_algo_desc aalg_list[] = {
> 	}
> },
> {
>-	.name = "hmac(ripemd160)",
>-	.compat = "ripemd160",
>+	.name = "hmac(rmd160)",
>+	.compat = "rmd160",

On the other hand you could rename the algorithm itself couldn't you?

Sebastian
--
To unsubscribe from this list: send the line "unsubscribe linux-crypto" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html

[Index of Archives]     [Kernel]     [Gnu Classpath]     [Gnu Crypto]     [DM Crypt]     [Netfilter]     [Bugtraq]

  Powered by Linux