On Thu, Feb 02, 2012 at 02:33:22PM +0200, Kirill A. Shutemov wrote: > On Wed, Feb 01, 2012 at 04:37:41AM +0100, Frederic Weisbecker wrote: > > +#if BITS_PER_LONG == 32 > > +void res_counter_write_u64(struct res_counter *counter, int member, u64 val) > > +{ > > + unsigned long long *target; > > + unsigned long flags; > > + > > + spin_lock_irqsave(&counter->lock, flags); > > + target = res_counter_member(counter, member); > > + *target = val; > > Nitpick: What's the point to have temporary variable here? Dunno, just a matter of habit, I use to avoid expressions like *func(foo) = bar. It looks less readable to me but perhaps it's because I'm not used to it. > > > + spin_unlock_irqrestore(&counter->lock, flags); > > +} > > +#else > > +void res_counter_write_u64(struct res_counter *counter, int member, u64 val) > > +{ > > + unsigned long long *target; > > + > > + target = res_counter_member(counter, member); > > + *target = val; > > Ditto. > > > +} > > +#endif > > -- > Kirill A. Shutemov _______________________________________________ Containers mailing list Containers@xxxxxxxxxxxxxxxxxxxxxxxxxx https://lists.linuxfoundation.org/mailman/listinfo/containers