On 02/21, Daniel Lezcano wrote: > > On 02/21/2011 05:01 AM, Serge E. Hallyn wrote: >> To do so we need to pass in the task_struct who'll get the utsname, >> so we can get its user_ns. >> >> -extern struct uts_namespace *copy_utsname(unsigned long flags, >> - struct uts_namespace *ns); >> +extern struct uts_namespace *copy_utsname(struct task_struct *tsk, >> + unsigned long flags, >> + struct uts_namespace *ns); > > Why don't we pass 'user_ns' instead of 'tsk' ? that will look > semantically clearer for the caller no ? > (example below). > ... > > new_nsp->uts_ns = copy_utsname(flags, tsk->nsproxy->uts_ns, task_cred_xxx(tsk, user)->user_ns); To me tsk looks more readable, I mean new_nsp->uts_ns = copy_utsname(flags, tsk); copy_utsname() can find both uts_ns and user_ns looking at task_strcut. But this is cosmetic and up to you and Serge. But. I think it makes sense to pass "tsk" argument to copy_pid_ns() as well. This way we can remove some CLONE_PIDNS code in copy_process(), and this looks like a nice cleanaup (even if minor) to me. Oleg. _______________________________________________ Containers mailing list Containers@xxxxxxxxxxxxxxxxxxxxxxxxxx https://lists.linux-foundation.org/mailman/listinfo/containers