On Mon, Jan 31, 2011 at 12:25 PM, Daniel Lezcano <daniel.lezcano@xxxxxxx> wrote: > The expressions tsk->nsproxy->pid_ns and task_active_pid_ns > aka ns_of_pid(task_pid(tsk)) should have the same number of > cache line misses with the practical difference that > ns_of_pid(task_pid(tsk)) is released later in a processes life. > > Furthermore by using task_active_pid_ns it becomes trivial > to write an unshare implementation for the the pid namespace. > > So I have used task_active_pid_ns everywhere I can. Yet current->nsproxy->pid_ns is way clearer. Because live current always has pid_ns. This task_active_pid_ns() is misnamed(?) because it does matter only for dead tasks? > - current->nsproxy->pid_ns->last_pid); > + task_active_pid_ns(current)->last_pid); I thought of doing exactly opposite patch :-) _______________________________________________ Containers mailing list Containers@xxxxxxxxxxxxxxxxxxxxxxxxxx https://lists.linux-foundation.org/mailman/listinfo/containers