On Mon, Jan 10, 2011 at 04:51:51PM -0600, Serge Hallyn wrote: > Quoting Bastian Blank (bastian@xxxxxxxxxxxx): > > Isn't that equal to this? > > > > if (ns_capable(tcred->user->user_ns, CAP_KILL)) > > return 1; > > > > if (cred->user->user_ns == tcred->user->user_ns && > > (cred->euid == tcred->suid || > > cred->euid == tcred->uid || > > cred->uid == tcred->suid || > > cred->uid == tcred->uid)) > > return 1; > > > > return 0; > > > > I would consider this much easier to read. > > Unfortunately, it's actually not equivalent. when capable() > returns success, then it sets the current->flags |= PF_SUPERPRIV. > If permission is granted based on userids and the capability > isn't needed, then we don't want to needlessly set PF_SUPERPRIV. Well, then switch the two if-clauses. What is this flag used for anyway? I only see it used in the accounting stuff, and if every user can get it, it is not longer useful. Bastian -- Bones: "The man's DEAD, Jim!" _______________________________________________ Containers mailing list Containers@xxxxxxxxxxxxxxxxxxxxxxxxxx https://lists.linux-foundation.org/mailman/listinfo/containers