On Mon, Jun 1, 2009 at 7:40 PM, Li Zefan <lizf@xxxxxxxxxxxxxx> wrote: > > We don't want users to use nopreifx, and also want to avoid name > collision, so we change to allow noprefix only if mounting just > the cpuset subsystem. > > Signed-off-by: Li Zefan <lizf@xxxxxxxxxxxxxx> > --- > kernel/cgroup.c | 10 ++++++++++ > 1 files changed, 10 insertions(+), 0 deletions(-) > > diff --git a/kernel/cgroup.c b/kernel/cgroup.c > index a7267bf..ad17f9d 100644 > --- a/kernel/cgroup.c > +++ b/kernel/cgroup.c > @@ -842,6 +842,11 @@ static int parse_cgroupfs_options(char *data, > struct cgroup_sb_opts *opts) > { > char *token, *o = data ?: "all"; > + unsigned long mask = (unsigned long)-1; Patch looks good, but to make it more self-explanatory how about calling this variable noprefix_conflict_mask ? Paul _______________________________________________ Containers mailing list Containers@xxxxxxxxxxxxxxxxxxxxxxxxxx https://lists.linux-foundation.org/mailman/listinfo/containers