Re: [PATCH 2/5] cifs: remove unneeded variable initialization in cifs_reconnect_tcon

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



This is fine, but what about this alternative (initializing variables
can make code easier to read, and given dumb compiler warnings
sometimes better to leave in variable initialization ...):

stevef@stevef-laptop:~/cifs-2.6$ git diff -a
diff --git a/fs/cifs/cifssmb.c b/fs/cifs/cifssmb.c
index 92e33d4..e4993a2 100644
--- a/fs/cifs/cifssmb.c
+++ b/fs/cifs/cifssmb.c
@@ -117,7 +117,7 @@ cifs_reconnect_tcon(struct cifs_tcon *tcon, int smb_command)
         * calling routine
         */
        if (!tcon)
-               return 0;
+               return rc;

        ses = tcon->ses;
        server = ses->server;


On Thu, Mar 31, 2011 at 4:36 PM, Jeff Layton <jlayton@xxxxxxxxxx> wrote:
> Reported-and-acked-by: David Howells <dhowells@xxxxxxxxxx>
> Signed-off-by: Jeff Layton <jlayton@xxxxxxxxxx>
> ---
>  fs/cifs/cifssmb.c |    2 +-
>  1 files changed, 1 insertions(+), 1 deletions(-)
>
> diff --git a/fs/cifs/cifssmb.c b/fs/cifs/cifssmb.c
> index 1622978..4f5c6d0 100644
> --- a/fs/cifs/cifssmb.c
> +++ b/fs/cifs/cifssmb.c
> @@ -106,7 +106,7 @@ static void mark_open_files_invalid(struct cifs_tcon *pTcon)
>  static int
>  cifs_reconnect_tcon(struct cifs_tcon *tcon, int smb_command)
>  {
> -       int rc = 0;
> +       int rc;
>        struct cifs_ses *ses;
>        struct TCP_Server_Info *server;
>        struct nls_table *nls_codepage;
> --
> 1.7.4
>
>



-- 
Thanks,

Steve
--
To unsubscribe from this list: send the line "unsubscribe linux-cifs" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html


[Linux USB Devel]     [Video for Linux]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]

  Powered by Linux