An RFC was sent last weekend to kick-off the discussion of the introduction of CAN XL [1]. While the series received some positive feedback, it is far from completion. Some work is still needed to: - adjust the nesting of the IFLA_CAN_XL_DATA_BITTIMING_CONST in the netlink interface - add the CAN XL PWM configuration and this TODO list may grow if more feedback is received. Regardless of this, the RFC started with a tree wide refactor followed by a set of trivial patches to do some clean-up and some renaming in preparation of the introduction of CAN XL. This series just contains those preparation patch which were cherry picked from the RFC and rebased on of top of linux-can-next/main: - the first patch group all the CAN FD parameters into a new structure. The plan is to reuse that same structure for CAN XL. - the second patch is purely cosmetic and fixes a trivial tabulation mistake. - the last three patches do some renaming: both the CAN FD and the CAN XL have databittiming parameters. In order not to get confused once CAN XL will be introduced, many symbols are modified to explicitly add CAN FD in their names. The goal is to have those merged first to remove some overhead from the netlink CAN XL main series before tacking care of the other comments. [1] [RFC] can: netlink: add CAN XL Link: https://lore.kernel.org/linux-can/20241110155902.72807-16-mailhol.vincent@xxxxxxxxxx/ Vincent Mailhol (5): can: dev: add struct data_bittiming_params to group FD parameters can: netlink: replace tabulation by space in assignment can: bittiming: rename CAN_CTRLMODE_TDC_MASK into CAN_CTRLMODE_FD_TDC_MASK can: bittiming: rename can_tdc_is_enabled() into can_fd_tdc_is_enabled() can: netlink: can_changelink(): rename tdc_mask into fd_tdc_flag_provided drivers/net/can/ctucanfd/ctucanfd_base.c | 8 +- drivers/net/can/dev/calc_bittiming.c | 2 +- drivers/net/can/dev/dev.c | 12 +-- drivers/net/can/dev/netlink.c | 100 +++++++++--------- drivers/net/can/flexcan/flexcan-core.c | 4 +- drivers/net/can/ifi_canfd/ifi_canfd.c | 10 +- drivers/net/can/kvaser_pciefd.c | 6 +- drivers/net/can/m_can/m_can.c | 8 +- drivers/net/can/peak_canfd/peak_canfd.c | 6 +- drivers/net/can/rcar/rcar_canfd.c | 4 +- .../net/can/rockchip/rockchip_canfd-core.c | 4 +- .../can/rockchip/rockchip_canfd-timestamp.c | 2 +- .../net/can/spi/mcp251xfd/mcp251xfd-core.c | 4 +- drivers/net/can/usb/esd_usb.c | 6 +- drivers/net/can/usb/etas_es58x/es58x_core.c | 4 +- drivers/net/can/usb/etas_es58x/es58x_fd.c | 8 +- drivers/net/can/usb/gs_usb.c | 8 +- drivers/net/can/usb/kvaser_usb/kvaser_usb.h | 2 +- .../net/can/usb/kvaser_usb/kvaser_usb_core.c | 6 +- drivers/net/can/usb/peak_usb/pcan_usb_core.c | 6 +- drivers/net/can/xilinx_can.c | 18 ++-- include/linux/can/bittiming.h | 2 +- include/linux/can/dev.h | 32 +++--- 23 files changed, 133 insertions(+), 129 deletions(-) -- 2.45.2