On Mon. 29 May 2023 at 22:42, Jimmy Assarsson <extja@xxxxxxxxxx> wrote: > This patch series contains various non critical fixes and improvments for > the kvaser_pciefd driver. > > Jimmy Assarsson (14): > can: kvaser_pciefd: Remove useless write to interrupt register > can: kvaser_pciefd: Remove handler for unused > KVASER_PCIEFD_PACK_TYPE_EFRAME_ACK > can: kvaser_pciefd: Add function to set skb hwtstamps > can: kvaser_pciefd: Set hardware timestamp on transmitted packets > can: kvaser_pciefd: Define unsigned constants with type suffix 'U' > can: kvaser_pciefd: Remove SPI flash parameter read functionality > can: kvaser_pciefd: Sort includes in alphabetic order > can: kvaser_pciefd: Rename device ID defines > can: kvaser_pciefd: Change return type for > kvaser_pciefd_{receive,transmit,set_tx}_irq() > can: kvaser_pciefd: Sort register definitions > can: kvaser_pciefd: Use FIELD_{GET,PREP} and GENMASK where appropriate > can: kvaser_pciefd: Add len8_dlc support > can: kvaser_pciefd: Refactor code > can: kvaser_pciefd: Use TX FIFO size read from CAN controller > > drivers/net/can/Kconfig | 3 +- > drivers/net/can/kvaser_pciefd.c | 955 ++++++++++++-------------------- > 2 files changed, 342 insertions(+), 616 deletions(-) > > -- > Changes in v2: > - Add new patches, to replace opencoded masking+shifting with > FIELD_{GET,PREP} and GENMASK, suggested by Vincent MAILHOL [1] Thanks for addressing my comments. Reviewed-by: Vincent Mailhol <mailhol.vincent@xxxxxxxxxx> > [1] https://lore.kernel.org/linux-can/5b10f6cd-c96c-3198-3df4-557e5e91b2e7@xxxxxxxxxx/T/#m14c3851e70cfb8c903388e068968a4a379d183e6 > > 2.40.0 >