Hello Jakub, hello David, this is a pull request of 14 patches for net-next/master. The first 7 patches are by Stephane Grosjean and Lukas Magel and target the peak_usb driver. Support for flashing a user defined device ID via the ethtool flash interface is added. A read only sysfs attribute for that value is added to distinguish between devices via udev. The next 2 patches are by me an fix minor coding style issues in the kvaser_usb driver. The last 5 patches are by Biju Das, target the rcar_canfd driver and clean up the support for different IP cores. regards, Marc --- The following changes since commit 02a97e02c64fb3245b84835cbbed1c3a3222e2f1: Merge tag 'mlx5-updates-2022-10-24' of git://git.kernel.org/pub/scm/linux/kernel/git/saeed/linux (2022-10-28 22:07:48 -0700) are available in the Git repository at: git://git.kernel.org/pub/scm/linux/kernel/git/mkl/linux-can-next.git tags/linux-can-next-for-6.2-20221031 for you to fetch changes up to 3755b56a9b8ff8f1a6a21a979cc215c220401278: Merge patch series "R-Car CAN FD driver enhancements" (2022-10-31 16:15:25 +0100) ---------------------------------------------------------------- linux-can-next-for-6.2-20221031 ---------------------------------------------------------------- Biju Das (5): can: rcar_canfd: rcar_canfd_probe: Add struct rcar_canfd_hw_info to driver data can: rcar_canfd: Add max_channels to struct rcar_canfd_hw_info can: rcar_canfd: Add shared_global_irqs to struct rcar_canfd_hw_info can: rcar_canfd: Add postdiv to struct rcar_canfd_hw_info can: rcar_canfd: Add multi_channel_irqs to struct rcar_canfd_hw_info Lukas Magel (2): can: peak_usb: export PCAN user device ID as sysfs device attribute can: peak_usb: align user device id format in log with sysfs attribute Marc Kleine-Budde (4): Merge patch series "can: peak_usb: Introduce configurable user dev id" can: kvaser_usb: kvaser_usb_set_bittiming(): fix redundant initialization warning for err can: kvaser_usb: kvaser_usb_set_{,data}bittiming(): remove empty lines in variable declaration Merge patch series "R-Car CAN FD driver enhancements" Stephane Grosjean (5): can: peak_usb: rename device_id to a more explicit name can: peak_usb: add callback to read user value of CANFD devices can: peak_usb: allow flashing of the user device id can: peak_usb: replace unregister_netdev() with unregister_candev() can: peak_usb: add ethtool interface to user defined flashed device number Documentation/ABI/testing/sysfs-class-net-peak_usb | 15 +++ drivers/net/can/rcar/rcar_canfd.c | 85 +++++++++------ drivers/net/can/usb/kvaser_usb/kvaser_usb_core.c | 4 +- drivers/net/can/usb/peak_usb/pcan_usb.c | 43 ++++++-- drivers/net/can/usb/peak_usb/pcan_usb_core.c | 119 +++++++++++++++++++-- drivers/net/can/usb/peak_usb/pcan_usb_core.h | 11 +- drivers/net/can/usb/peak_usb/pcan_usb_fd.c | 64 ++++++++++- drivers/net/can/usb/peak_usb/pcan_usb_pro.c | 26 ++++- drivers/net/can/usb/peak_usb/pcan_usb_pro.h | 1 + 9 files changed, 306 insertions(+), 62 deletions(-) create mode 100644 Documentation/ABI/testing/sysfs-class-net-peak_usb