On Tue, Mar 24, 2020 at 12:32 PM Alain Michaud <alainmichaud@xxxxxxxxxx> wrote: > > On Tue, Mar 24, 2020 at 2:35 PM Marcel Holtmann <marcel@xxxxxxxxxxxx> wrote: > > > > Hi Alain, > > > > >>>>>> This adds a bit mask of driver_info for Microsoft vendor extension and > > >>>>>> indicates the support for Intel 9460/9560 and 9160/9260. See > > >>>>>> https://docs.microsoft.com/en-us/windows-hardware/drivers/bluetooth/ > > >>>>>> microsoft-defined-bluetooth-hci-commands-and-events for more information > > >>>>>> about the extension. This was verified with Intel ThunderPeak BT controller > > >>>>>> where msft_vnd_ext_opcode is 0xFC1E. > > >>>> [] > > >>>>>> diff --git a/include/net/bluetooth/hci_core.h b/include/net/bluetooth/hci_core.h > > >>>> [] > > >>>>>> @@ -315,6 +315,10 @@ struct hci_dev { > > >>>>>> __u8 ssp_debug_mode; > > >>>>>> __u8 hw_error_code; > > >>>>>> __u32 clock; > > >>>>>> + __u16 msft_vnd_ext_opcode; > > >>>>>> + __u64 msft_vnd_ext_features; > > >>>>>> + __u8 msft_vnd_ext_evt_prefix_len; > > >>>>>> + void *msft_vnd_ext_evt_prefix; > > >>>> > > >>>> msft is just another vendor. > > >>>> > > >>>> If there are to be vendor extensions, this should > > >>>> likely use a blank line above and below and not > > >>>> be prefixed with msft_ > > >>> > > >>> there are other vendors, but all of them are different. So this needs to be prefixed with msft_ actually. But I agree that having empty lines above and below makes it more readable. > > >> > > >> So struct hci_dev should become a clutter > > >> of random vendor extensions? > > >> > > >> Perhaps there should instead be something like > > >> an array of char at the end of the struct and > > >> various vendor specific extensions could be > > >> overlaid on that array or just add a void * > > >> to whatever info that vendors require. > > > I don't particularly like trailing buffers, but I agree we could > > > possibly organize this a little better by with a struct. something > > > like: > > > > > > struct msft_vnd_ext { > > > bool supported; // <-- Clearly calls out if the > > > extension is supported. > > > __u16 msft_vnd_ext_opcode; // <-- Note that this also > > > needs to be provided by the driver. I don't recommend we have this > > > read from the hardware since we just cause an extra redirection that > > > isn't necessary. Ideally, this should come from the usb_table const. > > > > Actually supported == false is the same as opcode == 0x0000. And supported == true is opcode != 0x0000. > I was thinking of a more generic way to check if the extension is > supported so the higher level doesn't need to understand that > opcode==0 means it's not supported. For the android extension for > example, this would be a simple boolean (there isn't any opcodes). > > > > > __u64 msft_vnd_ext_features; > > > __u8 msft_vnd_ext_evt_prefix_len; > > > void *msft_vnd_ext_evt_prefix; > > > }; > > > > > > And then simply add the struct msft_vnd_ext (and any others) to hci_dev. > > > > Anyway, Lets keep these for now as hci_dev->msft_vnd_ext_*. We can fix this up later without any impact. > I agree, this doesn't have a whole lot of long term consequences, > although some will want to cherry-pick this to older kernels so if > there is something we can do now, it will reduce burden on some > products. Thanks for all your inputs. I will group these msft_vnd_ext_* into a struct msft_vnd_ext with future refactoring in mind if new extensions are introduced.