Hi Vladis, > Certain ttys operations (pty_unix98_ops) lack tiocmget() and tiocmset() > functions which are called by the certain HCI UART protocols (hci_ath, > hci_bcm, hci_intel, hci_mrvl, hci_qca) via hci_uart_set_flow_control() > or directly. This leads to an execution at NULL and can be triggered by > an unprivileged user. Fix this by adding a helper function and a check > for the missing tty operations in the protocols code. > > This fixes CVE-2019-10207. The Fixes: lines list commits where calls to > tiocm[gs]et() or hci_uart_set_flow_control() were added to the HCI UART > protocols. > > Link: https://syzkaller.appspot.com/bug?id=1b42faa2848963564a5b1b7f8c837ea7b55ffa50 > Reported-by: syzbot+79337b501d6aa974d0f6@xxxxxxxxxxxxxxxxxxxxxxxxx > Cc: stable@xxxxxxxxxxxxxxx # v2.6.36+ > Fixes: b3190df62861 ("Bluetooth: Support for Atheros AR300x serial chip") > Fixes: 118612fb9165 ("Bluetooth: hci_bcm: Add suspend/resume PM functions") > Fixes: ff2895592f0f ("Bluetooth: hci_intel: Add Intel baudrate configuration support") > Fixes: 162f812f23ba ("Bluetooth: hci_uart: Add Marvell support") > Fixes: fa9ad876b8e0 ("Bluetooth: hci_qca: Add support for Qualcomm Bluetooth chip wcn3990") > Signed-off-by: Vladis Dronov <vdronov@xxxxxxxxxx> > --- > > out-of-commit-message-note: > > it is possible that a HCI UART protocol uses serial device's > operations and not a tty ones. i made hci_uart_has_flow_control() to > check this also, hence the name. serial device's code checks if > the needed operations are present itself. > > i believe, hci_h5 does not need this check, as it uses serial device > functions only (as of now): > > serdev_device_set_flow_control(h5->hu->serdev, false); > serdev_device_set_baudrate(h5->hu->serdev, 115200); > > drivers/bluetooth/hci_ath.c | 3 +++ > drivers/bluetooth/hci_bcm.c | 3 +++ > drivers/bluetooth/hci_intel.c | 3 +++ > drivers/bluetooth/hci_ldisc.c | 7 +++++++ > drivers/bluetooth/hci_mrvl.c | 3 +++ > drivers/bluetooth/hci_qca.c | 3 +++ > drivers/bluetooth/hci_uart.h | 1 + > 7 files changed, 23 insertions(+) I changed the hci_uart_has_flow_control function into using more readable separate checks and then send the patch directly to Linus. Regards Marcel