Hi Inga, On 06/26, Inga Stotland wrote: > diff --git a/mesh/model.c b/mesh/model.c > index 9fd3aac6c..219371090 100644 > --- a/mesh/model.c > +++ b/mesh/model.c > @@ -55,10 +55,10 @@ struct mesh_model { > }; > > struct mesh_virtual { > - uint32_t id; /*Identifier of internally stored addr, min val 0x10000 */ > - uint16_t ota; > + uint32_t id; /* Internal ID of a stored virtual addr, min val 0x10000 */ > uint16_t ref_cnt; > - uint8_t addr[16]; > + uint16_t v_addr; /* 16-bit virtual address, used in messages */ Maybe nitpicking, but I would call this field just 'addr'. regards -- Michał Lowas-Rzechonek <michal.lowas-rzechonek@xxxxxxxxxxx> Silvair http://silvair.com Jasnogórska 44, 31-358 Krakow, POLAND