Re: [PATCH v2 1/2] Bluetooth: hci_qca: Rename STATE_<flags> to QCA_<flags>

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Mon, Apr 01, 2019 at 01:16:07PM +0530, Balakrishna Godavarthi wrote:
> Hi Matthias,
> 
> On 2019-03-13 02:12, Matthias Kaehlcke wrote:
> > Rename STATE_IN_BAND_SLEEP_ENABLED to QCA_IN_BAND_SLEEP_ENABLED.
> > The constant represents a flag (multiple flags can be set at once),
> > not a unique state of the controller or driver.
> > 
> > Also make the flag an enum value instead of a pre-processor constant
> > (more flags will be added to the enum group by another patch).
> > 
> > Signed-off-by: Matthias Kaehlcke <mka@xxxxxxxxxxxx>
> > ---
> > Changes in v2:
> > - don't use BIT()
> > - change to enum type
> > - updated commit message
> > ---
> >  drivers/bluetooth/hci_qca.c | 15 ++++++++-------
> >  1 file changed, 8 insertions(+), 7 deletions(-)
> > 
> > diff --git a/drivers/bluetooth/hci_qca.c b/drivers/bluetooth/hci_qca.c
> > index 237aea34b69f..1b7ba9e9e08a 100644
> > --- a/drivers/bluetooth/hci_qca.c
> > +++ b/drivers/bluetooth/hci_qca.c
> > @@ -54,9 +54,6 @@
> >  #define HCI_IBS_WAKE_ACK	0xFC
> >  #define HCI_MAX_IBS_SIZE	10
> > 
> > -/* Controller states */
> > -#define STATE_IN_BAND_SLEEP_ENABLED	1
> > -
> >  #define IBS_WAKE_RETRANS_TIMEOUT_MS	100
> >  #define IBS_TX_IDLE_TIMEOUT_MS		2000
> >  #define CMD_TRANS_TIMEOUT_MS		100
> > @@ -67,6 +64,10 @@
> >  /* Controller debug log header */
> >  #define QCA_DEBUG_HANDLE	0x2EDC
> > 
> > +enum qca_flags {
> > +	QCA_IN_BAND_SLEEP_ENABLED,
> > +};
> > +
> 
> [Bala]: I would recommend to go with QCA_IBS_ENABLED as IBS is abbreviated
> as In band sleep.

Sounds good, thanks for the suggestion!



[Index of Archives]     [Bluez Devel]     [Linux Wireless Networking]     [Linux Wireless Personal Area Networking]     [Linux ATH6KL]     [Linux USB Devel]     [Linux Media Drivers]     [Linux Audio Users]     [Linux Kernel]     [Linux SCSI]     [Big List of Linux Books]

  Powered by Linux