Hi Marcel, On Tue, Jul 05, 2016, Marcel Holtmann wrote: > The HCI_BREDR naming is confusing since it actually stands for Primary > Bluetooth Controller. Which is a term that has been used in the latest > standard. However from a legacy point of view there only really have > been Basic Rate (BR) and Enhanced Data Rate (EDR). Recent versions of > Bluetooth introduced Low Energy (LE) and made this terminology a little > bit confused since Dual Mode Controllers include BR/EDR and LE. To > simplify this the name HCI_PRIMARY stands for the Primary Controller > which can be a single mode or dual mode controller. > > Signed-off-by: Marcel Holtmann <marcel@xxxxxxxxxxxx> > --- > drivers/bluetooth/btmrvl_main.c | 2 +- > drivers/bluetooth/btsdio.c | 2 +- > drivers/bluetooth/btusb.c | 2 +- > drivers/bluetooth/hci_ldisc.c | 2 +- > drivers/bluetooth/hci_vhci.c | 6 +++--- > include/net/bluetooth/hci.h | 2 +- > net/bluetooth/hci_conn.c | 2 +- > net/bluetooth/hci_core.c | 28 +++++++++++++--------------- > net/bluetooth/hci_event.c | 2 +- > net/bluetooth/hci_sock.c | 2 +- > net/bluetooth/l2cap_core.c | 2 +- > net/bluetooth/mgmt.c | 16 ++++++++-------- > 12 files changed, 33 insertions(+), 35 deletions(-) All three patches have been applied to bluetooth-next. Thanks. Johan -- To unsubscribe from this list: send the line "unsubscribe linux-bluetooth" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html