Re: [BlueZ v6 00/13] Implement LE Advertisement D-Bus API

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Hi Michael,

On Fri, Mar 27, 2015 at 12:08 AM, Michael Janssen <jamuraa@xxxxxxxxxxxx> wrote:
> Implementation of the LE Advertisement D-Bus API.
>
> Things that are missing still (and added to the TODO):
>  * MGMT API for modifying the LE Advertisements
>  * Semantics for multiple Advertisements (currently any more than one will fail)
>  * TX Power property parsing / interface
>
> v1 -> v2:
>  * Cleanup based on comments from Arman
>  * Add g_dbus_proxy_set_read_watch function to avoid ObjectManager dependency
>  * Consolidate script updates into single test script
>
> v2 -> v3:
>  * Change "ManufacturerSpecificData" to "ManufacturerData"
>  * Add advertisement-api.txt to EXTRA_DIST
>  * Add Release() callback to org.bluez.LEAdvertisement1
>  * Remove IncludePower from the LEAdvertisement1 API
>
> v3 -> v4:
>  * Rename "g_dbus_proxy_set_read_watch" to "g_dbus_proxy_set_ready_watch"
>
> v4 -> v5:
>  * Rebase
>  * Use g_dbus_client_set_proxy_handlers instead of g_dbus_proxy_set_ready_watch
>  * Add MGMT interface calls to actually advertise.
>
> v5 -> v6:
>  * Minor patch cruft cleanup
>  * Rename btd_advertising_manager to btd_advertising and fix filename change.
>
>
> Michael Janssen (13):
>   core: advertising: add LEAdvertisingManager stubs
>   core/advertising: Implement RegisterAdvertisement
>   tools: Python script to test Advertisement API
>   core/advertising: implement UnregisterAdvertisement
>   shared: add advertising-data
>   core/advertising: use advertising_data
>   core/advertising: Parse ServiceUUIDs
>   core/advertising: Parse SolicitUUIDs
>   core/advertising: Parse ManufacturerSpecificData
>   core/advertising: Parse ServiceData
>   Update TODO for LE Advertising
>   shared/advertising: implement advertising_data_generate
>   core/advertising: Add and Remove AD using MGMT
>
>  Makefile.am                   |   3 +
>  TODO                          |  20 +-
>  src/adapter.c                 |  19 ++
>  src/advertising.c             | 665 ++++++++++++++++++++++++++++++++++++++++++
>  src/advertising.h             |  25 ++
>  src/shared/advertising-data.c | 585 +++++++++++++++++++++++++++++++++++++
>  src/shared/advertising-data.h |  69 +++++
>  tools/advertisement-example   | 170 +++++++++++
>  8 files changed, 1546 insertions(+), 10 deletions(-)
>  create mode 100644 src/advertising.c
>  create mode 100644 src/advertising.h
>  create mode 100644 src/shared/advertising-data.c
>  create mode 100644 src/shared/advertising-data.h
>  create mode 100644 tools/advertisement-example
>
> --
> 2.2.0.rc0.207.ga3a616c

Ive applied patches 1-4, now for shared I think it is better to use
bt_ prefix, perhaps bt_advertisement or bt_ad if the former makes the
functions name too big.


-- 
Luiz Augusto von Dentz
--
To unsubscribe from this list: send the line "unsubscribe linux-bluetooth" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html




[Index of Archives]     [Bluez Devel]     [Linux Wireless Networking]     [Linux Wireless Personal Area Networking]     [Linux ATH6KL]     [Linux USB Devel]     [Linux Media Drivers]     [Linux Audio Users]     [Linux Kernel]     [Linux SCSI]     [Big List of Linux Books]

  Powered by Linux