Hi Marcel, >> - if (!test_and_set_bit(HCI_CONN_MGMT_CONNECTED, &conn->flags)) >> + if (!test_and_set_bit(HCI_CONN_MGMT_CONNECTED, &conn->flags)) { >> mgmt_device_connected(hdev, &conn->dst, conn->type, >> - conn->dst_type, 0, NULL, 0, NULL); >> + conn->dst_type, 0, NULL, 0, NULL, >> + conn->le_pend_adv_data, >> + conn->le_pend_adv_len); >> + conn->le_pend_adv_len = 0; > > The reset to 0 seems like not a good idea. What is this trying to fix. It just made it consistent with the naming (it's not pending anymore once you send it). Now that the naming changed it doesn't make sense, I will remove it. All your remarks have been taken care of in patch version 2. -- Alfonso Acosta Embedded Systems Engineer at Spotify Birger Jarlsgatan 61, Stockholm, Sweden http://www.spotify.com -- To unsubscribe from this list: send the line "unsubscribe linux-bluetooth" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html