Re: [PATCH] android/ipc: Rename connect_sco to get_fd

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Hi Andrei,

On Fri, Jul 18, 2014, Andrei Emeltchenko wrote:
> SCO get connected through handsfree HAL and Audio SCO HAL only need to
> get SCO socket fd.
> ---
>  android/hal-sco.c       |  4 ++--
>  android/handsfree.c     | 10 +++++-----
>  android/sco-ipc-api.txt |  6 +++---
>  android/sco-msg.h       |  4 ++--
>  4 files changed, 12 insertions(+), 12 deletions(-)
> 
> diff --git a/android/hal-sco.c b/android/hal-sco.c
> index 0e87aad..e07bb9a 100644
> --- a/android/hal-sco.c
> +++ b/android/hal-sco.c
> @@ -285,12 +285,12 @@ static int ipc_connect_sco(void)

Shouldn't you change the name of this ipc_connect_sco function too?

>  	pthread_mutex_lock(&sco_mutex);
>  
>  	if (sco_fd < 0) {
> -		struct sco_rsp_connect rsp;
> +		struct sco_rsp_get_fd rsp;
>  		size_t rsp_len = sizeof(rsp);
>  
>  		DBG("Connecting SCO");

And this debug log?

Johan
--
To unsubscribe from this list: send the line "unsubscribe linux-bluetooth" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html




[Index of Archives]     [Bluez Devel]     [Linux Wireless Networking]     [Linux Wireless Personal Area Networking]     [Linux ATH6KL]     [Linux USB Devel]     [Linux Media Drivers]     [Linux Audio Users]     [Linux Kernel]     [Linux SCSI]     [Big List of Linux Books]

  Powered by Linux