Re: [PATCH 2/2] android: Add supported uuids when adapter initialized

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Hi Marcin,

On Wed, Oct 30, 2013, Marcin Kraglak wrote:
> +/*
> + * This is an array of supported uuids and service hints. We add them via mgmt
> + * interface when adapter is initialized. Uuids are in reverse orded.
> + */
> +static const struct mgmt_cp_add_uuid sup_uuids[] = {
> +	/* OBEX */
> +	{{0xfb, 0x34, 0x9b, 0x5f, 0x80, 0x00, 0x00, 0x80, 0x00,
> +	0x10, 0x00, 0x00, 0x05, 0x11, 0x00, 0x00}, 0x10},
> +	/* TELEPHONY */
> +	{{0xfb, 0x34, 0x9b, 0x5f, 0x80, 0x00, 0x00, 0x80, 0x00,
> +	0x10, 0x00, 0x00, 0x1f, 0x11, 0x00, 0x00}, 0x40},
> +	/* CAPTURING */
> +	{{0xfb, 0x34, 0x9b, 0x5f, 0x80, 0x00, 0x00, 0x80, 0x00,
> +	0x10, 0x00, 0x00, 0x0d, 0x11, 0x00, 0x00}, 0x08},
> +	/* NETWORKING */
> +	{{0xfb, 0x34, 0x9b, 0x5f, 0x80, 0x00, 0x00, 0x80, 0x00,
> +	0x10, 0x00, 0x00, 0x15, 0x11, 0x00, 0x00}, 0x02} };

I think you should at least mention here exactly which UUIDs you're
adding. It looks like it's OPP, HFP AG, Advanced Audio and PANU but it'd
be nicer to be clear about this in the code comment.

The table would also be more readable if you did something like

static const struct mgmt_cp_add_uuid uuids[] = {
	{ .uuid = ...,
	  .svc_hint = ... },
	{ .uuid = ...,
	  .svc_hint = ... },
};

Note that our coding style puts a space after { and before }.

Johan
--
To unsubscribe from this list: send the line "unsubscribe linux-bluetooth" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html




[Index of Archives]     [Bluez Devel]     [Linux Wireless Networking]     [Linux Wireless Personal Area Networking]     [Linux ATH6KL]     [Linux USB Devel]     [Linux Media Drivers]     [Linux Audio Users]     [Linux Kernel]     [Linux SCSI]     [Big List of Linux Books]

  Powered by Linux