Hi Andre, > As hci_acl_disconn function basically sends the HCI Disconnect Command > and it is used to disconnect both ACL and LE links, renaming it to > hci_disconnect is more suitable. > > Signed-off-by: Andre Guedes <andre.guedes@xxxxxxxxxxxxx> > --- > include/net/bluetooth/hci_core.h | 2 +- > net/bluetooth/hci_conn.c | 4 ++-- > net/bluetooth/hci_core.c | 2 +- > net/bluetooth/hci_event.c | 4 ++-- > 4 files changed, 6 insertions(+), 6 deletions(-) > > diff --git a/include/net/bluetooth/hci_core.h b/include/net/bluetooth/hci_core.h > index bcf8ffe..def944d 100644 > --- a/include/net/bluetooth/hci_core.h > +++ b/include/net/bluetooth/hci_core.h > @@ -573,7 +573,7 @@ static inline struct hci_conn *hci_conn_hash_lookup_state(struct hci_dev *hdev, > return NULL; > } > > -void hci_acl_disconn(struct hci_conn *conn, __u8 reason); > +void hci_disconnect(struct hci_conn *conn, __u8 reason); > void hci_setup_sync(struct hci_conn *conn, __u16 handle); > void hci_sco_setup(struct hci_conn *conn, __u8 status); a better name might be hci_conn_disconnect, but I do realize that overlaps with the timeout callback. And we have not been really super strict with the function name prefixes anyway. Regards Marcel -- To unsubscribe from this list: send the line "unsubscribe linux-bluetooth" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html