Hi Andrei, > > > - > > > +struct hci_chan *hci_chan_lookup_handle(struct hci_conn *hcon, __u16 handle); > > > +struct hci_chan *hci_chan_lookup_handle_all(struct hci_dev *hdev, > > > + __u16 handle); > > > > this naming is pretty bad. I have no idea what one function does > > different compared to the other. Especially since none of them take a > > hci_chan as argument, but start with that prefix. > > > > Would be the naming hci_conn_lookup_chan be a lot clearer? Or maybe > > hci_chan_lookup_from_dev or similar. > > So are names like: > > hci_conn_lookup_hchan_by_handle since this one is only internal, you better have a shortcut version as just a static helper inside that code. > hci_conn_lookup_hchan_from_hdev If we follow our naming convention then hci_chan_lookup_from_dev would come closest. However since you only need one of these, then hci_chan_lookup_handle would be fine and in sync with how we named everything else. I rather not have the prefixing h everywhere that we use in variable names. That should be really only for variable names. Regards Marcel -- To unsubscribe from this list: send the line "unsubscribe linux-bluetooth" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html