Hi Chan-yeol, > > #define SBC_SAMPLING_FREQ_16000 (1 << 3) > > #define SBC_SAMPLING_FREQ_32000 (1 << 2) > > @@ -114,3 +115,8 @@ typedef struct { > > #else > > #error "Unknown byte order" > > #endif > > + > > +typedef struct { > > + uint8_t vendor_id[4]; > > + uint8_t codec_id[2]; > > +} __attribute__ ((packed)) non_a2dp_vendor_codec_t; > > We normally don't typedef this type of structs, besides > > a2dp_vendor_codec should be enough so this should be named struct > > a2dp_vendor_codec. > You're right. originally I didn't use typedef. > but in order to achieve harmony in a2dp-codecs.h like sbc,mpeg, I've > changed it. > > If you make decision about this, I will raise a second patch. hold on for a second, is this the file that is shared with PulseAudio? Regards Marcel -- To unsubscribe from this list: send the line "unsubscribe linux-bluetooth" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html