[PATCH v3 0/7] Bluetooth: Refactoring hci_connect()

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Hi,

Changes from last version:
 * Changed the names of the functions that send HCI Commands to avoid confusion;
 * There was no need for exporting some functions related to connections;

Cheers,

Vinicius Costa Gomes (7):
  Bluetooth: Remove some functions from being exported
  Bluetooth: Rename LE and ACL connection functions
  Bluetooth: Refactor LE connection into its own function
  Bluetooth: Refactor ACL connection into its own function
  Bluetooth: Refactor SCO connection into its own function
  Bluetooth: Simplify a the connection type handling
  Bluetooth: Add type information to the hci_connect() debug statement

 include/net/bluetooth/hci_core.h |    2 -
 net/bluetooth/hci_conn.c         |   99 ++++++++++++++++++++++++--------------
 2 files changed, 62 insertions(+), 39 deletions(-)

--
1.7.10.4
--
To unsubscribe from this list: send the line "unsubscribe linux-bluetooth" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html


[Index of Archives]     [Bluez Devel]     [Linux Wireless Networking]     [Linux Wireless Personal Area Networking]     [Linux ATH6KL]     [Linux USB Devel]     [Linux Media Drivers]     [Linux Audio Users]     [Linux Kernel]     [Linux SCSI]     [Big List of Linux Books]

  Powered by Linux