Hi Vinicius, * Vinicius Costa Gomes <vinicius.gomes@xxxxxxxxxxxxx> [2012-05-31 22:57:53 -0300]: > The hci_connect() function was starting to get too complicated to be > quickly understood. We can separated the creation of a new ACL > connection into its own function. > > Signed-off-by: Vinicius Costa Gomes <vinicius.gomes@xxxxxxxxxxxxx> > --- > net/bluetooth/hci_conn.c | 32 ++++++++++++++++++++++---------- > 1 file changed, 22 insertions(+), 10 deletions(-) > > diff --git a/net/bluetooth/hci_conn.c b/net/bluetooth/hci_conn.c > index 31afef7..79c80b2 100644 > --- a/net/bluetooth/hci_conn.c > +++ b/net/bluetooth/hci_conn.c > @@ -496,18 +496,10 @@ static struct hci_conn *hci_connect_le(struct hci_dev *hdev, bdaddr_t *dst, > return le; > } > > -/* Create SCO, ACL or LE connection. > - * Device _must_ be locked */ > -struct hci_conn *hci_connect(struct hci_dev *hdev, int type, bdaddr_t *dst, > - __u8 dst_type, __u8 sec_level, __u8 auth_type) > +static struct hci_conn *hci_connect_acl(struct hci_dev *hdev, bdaddr_t *dst, > + u8 sec_level, u8 auth_type) > { So this is confusing now, we have hci_acl_connect() and now you want to add hci_connect_acl(). We need better names here. Maybe hci_acl_connect() can be turned int hci_acl_create_connetion(), so can hco_acl_connect_cancel(). Gustavo -- To unsubscribe from this list: send the line "unsubscribe linux-bluetooth" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html