Hi Chen, On Wed, Mar 28, 2012, chen.ganir@xxxxxx wrote: > +struct deviceinfo { > + struct btd_device *dev; /* Device reference */ > +}; Would it make sense to use device_info instead of deviceinfo? Or maybe just di? In general I'm not so happy with this long word though I'm not sure what the best replacement for it would be. Same goes for the subdirectory and the filenames. > +static GSList *deviceinfoservers = NULL; You could call this just "servers" since it's static and already inside a file called deviceinfo.c. > +static void deviceinfo_exit(void) > +{ > + if (!main_opts.gatt_enabled) > + return; > + > + deviceinfo_manager_exit(); > +} I think it's a bug if *_exit() gets called even if *_init() failed. So probably the check for gatt_enabled is unnecessary here. Johan -- To unsubscribe from this list: send the line "unsubscribe linux-bluetooth" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html