[PATCH obexd v2 0/4] client: parameter naming convention

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



From: Mikel Astiz <mikel.astiz@xxxxxxxxxxxx>

These patches review the naming convention in transfer.h and session.h, in order to avoid misleading use of the terms "name", "filename" and "targetname".

This second proposal splits the first patch into two patches, and avoids a bug that would have been introduced: the reply of the agent needs to be handled with care, since depending on the operation type (put or get) the reply of the agent should overwrite one field or the other.

Mikel Astiz (4):
  client: add obc_transfer_set_filename
  client: fix naming convention in transfer api
  client: refactor naming convention in session api
  client: simplify obc_session_pull

 client/session.c  |   55 ++++++++++++++++++----------------------------------
 client/session.h  |   12 +++++-----
 client/transfer.c |   14 +++++++++---
 client/transfer.h |    2 +
 4 files changed, 37 insertions(+), 46 deletions(-)

-- 
1.7.6.5

--
To unsubscribe from this list: send the line "unsubscribe linux-bluetooth" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html


[Index of Archives]     [Bluez Devel]     [Linux Wireless Networking]     [Linux Wireless Personal Area Networking]     [Linux ATH6KL]     [Linux USB Devel]     [Linux Media Drivers]     [Linux Audio Users]     [Linux Kernel]     [Linux SCSI]     [Big List of Linux Books]

  Powered by Linux