Hi Marcel, Gustavo, On Thu, Feb 09, 2012 at 04:13:31PM -0200, Gustavo Padovan wrote: > > > +static inline void __l2cap_set_sock_err(struct l2cap_chan *chan, int err) > > > +{ > > > + struct sock *sk = chan->sk; > > > + > > > + sk->sk_err = err; > > > +} > > > + > > > +static inline void l2cap_set_sock_err(struct l2cap_chan *chan, int err) > > > +{ > > > + struct sock *sk = chan->sk; > > > + > > > + lock_sock(sk); > > > + __l2cap_set_sock_err(chan, err); > > > + release_sock(sk); > > > +} > > > > I think we better call this l2cap_chan_set_sock_err(). Sounds kinda > > long, but makes it a bit more clearer what it does. > > Or l2cap_chan_set_err() since this will be made generic once the separation > between core and sock is done. So which of the proposed names better to use? Both looks OK. Best regards Andrei Emeltchenko -- To unsubscribe from this list: send the line "unsubscribe linux-bluetooth" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html