Hi Andrei, On Fri, Dec 9, 2011 at 9:10 AM, Emeltchenko Andrei <Andrei.Emeltchenko.news@xxxxxxxxx> wrote: > From: Andrei Emeltchenko <andrei.emeltchenko@xxxxxxxxx> > > Add general HCI callback implementation. Can be used for executing > HCI commands from A2MP protocol. > --- > include/net/bluetooth/hci_core.h | 14 +++++++++++ > net/bluetooth/hci_core.c | 47 ++++++++++++++++++++++++++++++++++++++ > net/bluetooth/hci_event.c | 4 +++ > 3 files changed, 65 insertions(+), 0 deletions(-) > > diff --git a/include/net/bluetooth/hci_core.h b/include/net/bluetooth/hci_core.h > index cc5481d..e473cd2 100644 > --- a/include/net/bluetooth/hci_core.h > +++ b/include/net/bluetooth/hci_core.h > @@ -121,6 +121,15 @@ struct adv_entry { > u8 bdaddr_type; > }; > > +struct hci_dev; > + > +struct cb_cmd { > + struct list_head list; > + u16 opcode; > + void *opt; > + void (*cb)(struct hci_dev *hdev, void *opt); > +}; > + Isn't this a too generic name for an exported struct, which may cause clashes? Regards, -- Anderson Lizardo Instituto Nokia de Tecnologia - INdT Manaus - Brazil -- To unsubscribe from this list: send the line "unsubscribe linux-bluetooth" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html