Hi Chan-yeol, On Tue, Oct 18, 2011, chanyeol.park@xxxxxxxxxxx wrote: > From: Chan-yeol Park <chanyeol.park@xxxxxxxxxxx> > > --- > src/eir.c | 2 +- > 1 files changed, 1 insertions(+), 1 deletions(-) > > diff --git a/src/eir.c b/src/eir.c > index e82d30b..b76bfa2 100644 > --- a/src/eir.c > +++ b/src/eir.c > @@ -70,7 +70,7 @@ int eir_parse(struct eir_data *eir, uint8_t *eir_data) > uuid_t service; > char *uuid_str; > const char *name = NULL; > - size_t name_len; > + size_t name_len = 0; > unsigned int i; > > eir->flags = -1; This was already discussed on the list: http://www.spinics.net/lists/linux-bluetooth/msg17222.html It's essentially a gcc bug which doesn't show up with newer gcc versions. Instead of adding this unnecessary initialization, Marcels proposal was to rewrite the eir_parse function since its logic is quite hard to follow right now. Johan -- To unsubscribe from this list: send the line "unsubscribe linux-bluetooth" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html