Hi Gustavo, On Wed, Jul 13, 2011 at 5:26 PM, Gustavo Padovan <padovan@xxxxxxxxxxxxxx> wrote: >> @@ -202,6 +202,7 @@ enum { >> >> #define LMP_EV4 0x01 >> #define LMP_EV5 0x02 >> +#define LMP_NO_BREDR 0x20 >> #define LMP_LE 0x40 >> >> #define LMP_SNIFF_SUBR 0x02 >> diff --git a/include/net/bluetooth/hci_core.h b/include/net/bluetooth/hci_core.h >> index 1ff59f2..fc75c61 100644 >> --- a/include/net/bluetooth/hci_core.h >> +++ b/include/net/bluetooth/hci_core.h >> @@ -597,6 +597,7 @@ void hci_conn_del_sysfs(struct hci_conn *conn); >> #define lmp_esco_capable(dev) ((dev)->features[3] & LMP_ESCO) >> #define lmp_ssp_capable(dev) ((dev)->features[6] & LMP_SIMPLE_PAIR) >> #define lmp_no_flush_capable(dev) ((dev)->features[6] & LMP_NO_FLUSH) >> +#define lmp_no_bredr_capable(dev) ((dev)->features[4] & LMP_NO_BREDR) > > It's more logic call this lmp_bredr_capable() regardless what the bit really > means. I agree. I was concerned about having a *_capable macro with different meaning from the LMP bit. Since you agree too, I'll change this. Thanks. Andre -- To unsubscribe from this list: send the line "unsubscribe linux-bluetooth" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html