Hi Bastien, On Wed, Jun 8, 2011 at 1:43 PM, Bastien Nocera <hadess@xxxxxxxxxx> wrote: > <snip> >> > - if (read_local_name(&adapter->bdaddr, adapter->name) < 0) >> > - expand_name(adapter->name, MAX_NAME_LENGTH, main_opts.name, >> > - adapter->dev_id); >> > - >> > - if (main_opts.attrib_server) >> > - attrib_gap_set(GATT_CHARAC_DEVICE_NAME, >> > - (const uint8_t *) adapter->name, strlen(adapter->name)); >> >> I can't find where you moved the attrib_gap_set() call to. This is >> necessary for GATT attribute server. > > Check the code instead of the patch, it's already done in > adapter_update_local_name(). In this case, it is better if you put this cleanup/refactor in a separate patch. IMHO, you are doing two things on the same patch: 1) moving things to a plugin and removing duplicated code. 2) adding support for /etc/machine-info These could be split in two patches. This facilitates tracking regressions (if any) later by bisect. Regards, -- Anderson Lizardo Instituto Nokia de Tecnologia - INdT Manaus - Brazil -- To unsubscribe from this list: send the line "unsubscribe linux-bluetooth" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html