Hi Rafal, On Tue, May 31, 2011, Rafal Michalski wrote: > + guint timer_id; Please call this off_timer. > + adapter->timer_id = g_timeout_add_seconds(3, > + switch_off_timeout, adapter); No magic constants whenever possible so please add a OFF_TIMER define to the beginning of the file. Also, it seems like you're missing the timer removal in the adapter_free function. It would be pretty bad if the timer goes off after the adapter object has already been freed. Johan -- To unsubscribe from this list: send the line "unsubscribe linux-bluetooth" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html