Hi Waldek, On Mon, May 30, 2011, Waldemar Rymarkiewicz wrote: > @@ -387,8 +385,10 @@ static int disconnect_req(struct sap_connection *conn, uint8_t disc_type) > > case SAP_DISCONNECTION_TYPE_CLIENT: > if (conn->state != SAP_STATE_CONNECTED && > - conn->state != SAP_STATE_GRACEFUL_DISCONNECT) > - goto error_rsp; > + conn->state != SAP_STATE_GRACEFUL_DISCONNECT) { > + sap_error_rsp(conn); > + goto error_req; > + } Since all of the case statements return from the function in the non-error case, and all the error_req label is doing is a single return statment, I think it'd be cleaner (easier to follow the code flow) by removing the label and do "return -EPERM;" directly instead of a goto. Johan -- To unsubscribe from this list: send the line "unsubscribe linux-bluetooth" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html